Why doesn’t my module or video play?

Some modules of this training require the use of the Adobe Flash Player. You may need to install Adobe Flash Player and/or activate it to run on the search-training.org website. The link below explains how to install Adobe Flash Player on your computer and enable it to run in your web browser.
Adobe Flash Player Help

We recommend using Mozilla Firefox (v. 48 or newer) or Google Chrome (v. 52 or newer) for the best user experience. If you are using one of the preferred browsers listed above and are still not able to play the video, please contact your IT department. The video may be blocked by a firewall in which case your IT department may need to whitelist the search-training.org domain. Some courses may also include embedded videos from Vimeo and/or YouTube.

January 9, 2019
X